We found that there was a vulnerability in the previous auth service, please use this one instead:
(Backup copy of binary available here)
Source code here